- Vous êtes ici :
-
Accueil
-
blog / tutoriels
- blog / tutoriels
Nous proposons à la communauté des tutoriels au gré de nos humeurs, de l'actualité et des besoins.
( n'hésitez pas, par ailleurs à nous en demander)
Quelques articles sur l'actualité de Web54 et de ce qu'il se passe au niveau internet en Lorraine
Tutoriels sur Gantry, Vertex, Helix ... etc ...
(documentation personnelle ou traduction de la documentation originale)
La création de site internet, necessite des logiciels.
En lorraine, certains créateurs de sites utilisent des logiciels libres et en font la promotion.
Serge Billon en fait partie, et vous fait partager ici, en tant que webmaster reconnu sur Nancy et sa région, sa passion pour les logiciels libres.
Référencer un site n'est souvent pas une partie de plaisir, ni une formalité.
C'est pourquoi nous proposons des prestations en référencement, sur forfait ou sur devis personnalisé.
Toutefois, nous tenons à proposer une méthodologie aux clients qui voudraient tenter l'aventure et procéder eux-même à leur référencement.
Suivez les étapes pas à pas, et faites progresser votre site dans les méandres des moteurs de recherche.
Tutoriels en français des composants RS
La récente version de Joomla 3.9.16 inclut l'ajout d'un index de base de données à la table des utilisateurs. Si votre site web Joomla a des noms d'utilisateurs en double, cet ajout d'index échouera et vous verrez une erreur comme dans l'image ci-jointe. Le reste de la mise à jour se déroulera normalement sans problème.
Si vous avez cette erreur, vous devez d'abord trouver et résoudre les problèmes de doublons de noms d'utilisateur. Chaque nom d'utilisateur de votre site doit être unique, vous devez donc soit le renommer, soit supprimer les doublons.
Vous pouvez le faire à la main en allant dans la gestion des utilisateurs de votre administration Joomla
Pour trouver les doublons, vous pouvez aussi lancer la commande MySQL suivante dans PhpMyadmin (remplacez #_ avec le préfixe de vos tables)
SELECT username FROM #__users GROUP BY username HAVING COUNT(*) > 1
Une fois que vous avez résolu ce problème, vous pouvez naviguer jusqu'à la fonction de correction de la base de données et l'exécuter pour ajouter l'index manquant. Pour ce faire, allez dans Extensions > Gérer > Base de données et cliquez sur le bouton "Réparer".
Si vous rencontrez des problèmes avec ce correctif, n'hésitez pas à nous contacter !
Chez L'hébergeur OVH de nombreux sites voient le système de mise à jour retourner ce genre d'erreurs :
Update: Could not open update site #1 "Joomla! Core", URL: https://update.joomla.org/core/list.xml
Cette erreur empêche votre site de télécharger les mises à...
Lire → Erreur OVH "Update: Could not open update site #1 "Joomla! Core", URL:...
Une demande de certains clients et souvent des graphistes est de pouvoir mettre une image d'entête selon chaque article Joomla.
Il ne s'agit pas d'une image aléatoire mais bel et bien d'une image que l'on aura choisie et qui viendra s'afficher...
Lire → Ajouter une image d'entête personnalisée par article joomla
Vous aviez l’habitude (ou pas) de créer des menus cachés dans votre arborescence Joomla ?
Une nouvelle fonctionnalité va vous faire gagner du temps et vous apporter de l’efficacité de travail.
Par défaut, Joomla ajoute l'ID de l'article dans les URL des articles et des catégories. Pour des raisons esthétiques, ou pour votre SEO Joomla, il est parfois nécessaire de supprimer ces numéros de vos URL. Certains logiciels de réécriture SEO le font (SH404SEF, Acesef...), mais vous pouvez implémenter vous-même la fonctionnalité dans votre Joomla.
Lire la suite : Supprimer l'ID de l'article dans les URL de Joomla