Erreur OVH "Update: Could not open update site #1 "Joomla! Core", URL: https://update.joomla.org/core/list.xml" : La solution !

 

Chez L'hébergeur OVH de nombreux sites voient le système de mise à jour retourner ce genre d'erreurs :

Update: Could not open update site #1 "Joomla! Core", URL: https://update.joomla.org/core/list.xml

Cette erreur empêche votre site de télécharger les mises à jour depuis les serveurs de Joomla, mais pas sur tous les serveurs OVH.

Notre confrêre Marc Dechèvre de l'agence WOLUWEB avait soulevé ce lièvre il y a quelques mois sans que les services techniques d'OVH, ni les forums Joomla.org n'aient pu trouver d'où venait l'erreur.

Ayant été nous-même victime de ce disfonctionnement, nous avons fait des recherches pour comprendre le fonctionnement et les appels des différents serveurs.

Tous le monde se rejetait la balle, et les webmasters au milieu continuaient à devoir faire les mises à jour à la main ... pauvres de nous.

Mais au détour d'une explication, nous est apparu que le serveur Joomla, en communicant vers le site Joomla, interrogeait un fichier sur le serveur :

/libraries/src/Http/Transport/cacert.pem

Après vérification : le fichier en question était vide sur les serveurs en question ... 

La solution est donc de remplacer le fichier vide par un complet d'une autre installation ou par celui existant sur le dépôt Joomla : 

https://github.com/joomla/joomla-cms/blob/staging/libraries/src/Http/Transport/cacert.pem

Il semble que cette solution fonctionne sur les sites ayant rencontré le souci, mais nous ne savons toujours pas pourquoi le fichier s'est retrouvé vide.

Toujours est-il que La TEAM JOOMLA LORRAINE est heureuse d'avoir pu aider nos amis Wallons et résoudre enfin ce post datant de 30 mois sur le forum JOOMLA

Donnez une note !
5 sur 5 - 1 votes
Merci d'avoir noté cet article.

Contact

Parlons social

Recevoir des nouvelles du site

 

patenaire paypal